[PATCH] [2/7] x86_64: Fix no IOMMU warning in PCI-GART driver

Andi Kleen ak at suse.de
Mon May 29 00:17:53 CEST 2006


Complaining about the IOMMU not compiled in doesn't make sense
here because it is clearly compiled in.

Signed-off-by: Andi Kleen <ak at suse.de>

---
 arch/x86_64/kernel/pci-gart.c |    6 ++----
 1 files changed, 2 insertions(+), 4 deletions(-)

Index: linux-2.6.17-rc5/arch/x86_64/kernel/pci-gart.c
===================================================================
--- linux-2.6.17-rc5.orig/arch/x86_64/kernel/pci-gart.c
+++ linux-2.6.17-rc5/arch/x86_64/kernel/pci-gart.c
@@ -631,10 +631,8 @@ static int __init pci_iommu_init(void)
 		printk(KERN_INFO "PCI-DMA: Disabling IOMMU.\n");
 		if (end_pfn > MAX_DMA32_PFN) {
 			printk(KERN_ERR "WARNING more than 4GB of memory "
-					"but IOMMU not compiled in.\n"
-			       KERN_ERR "WARNING 32bit PCI may malfunction.\n"
-			       KERN_ERR "You might want to enable "
-					"CONFIG_GART_IOMMU\n");
+					"but IOMMU not available.\n"
+			       KERN_ERR "WARNING 32bit PCI may malfunction.\n");
 		}
 		return -1;
 	}



More information about the discuss mailing list